OtherSoftware

Chair for Computer Aided Medical Procedures & Augmented Reality
Lehrstuhl für Informatikanwendungen in der Medizin & Augmented Reality

Third-party software used in DWARF

DWARF uses several third-party software components. The vital ones are open source, although we can also take advantage of proprietary components.

Here is a list, taken from the QUICKSTART file in our CVS distribution:


RPMS for all packages (that aren't available with std. Distributions) are available here (SuSE8.x and SuSE9.0);
Instructions how to setup all 3rd party software on Mac OS X can be found on MacOSXFinkPackages

GNU autotools

The GNU autotools are at the center of the DWARF build process. If you want to write your own service and that service integrates 3rd party software, you must read at least the autoconf and automake manuals. For further information, you may read the DwarfBuildTutorial or contact MartinWagner?.
  • automake (v1.6 or higher) - Documentation
  • autoconf (v2.52 or higher) - Documentation
  • libtool (v1.4.1 or higher) - Documentation
    Note: you must use v1.5 on Mac OS X, otherwise spurious crashes will occur

OmniORB (v3.0.x or 4.0.x)

http://www.uk.research.att.com/omniORB/

Necessary for all C++-based components, including the service manager.

omniNotify (v1.1 or higher)

http://www.research.att.com/~ready/omniNotify/index.html

Necessary for event-based communication.

openSLP (v.1.0.6 or higher)

http://www.openslp.org/

Necessary for distribution of services, easy installation. Installed at the Linux envirnoment, for Mac OS X the default Apple slp daemon has to be replaced by the openSLP daemon.

Please note: v1.0.9 will not work with DWARF.

The download of old openSLP versions may not be linked directly from the webpage, however, this link will help you: http://prdownloads.sourceforge.net/openslp

OpenORB (v1.2.0 or higher)

http://openorb.exolab.org/

Necessary for all Java-based components.

Xerces-C (v2.1.0 or higher)

http://xml.apache.org/

Necessary for all components using XML, including service descriptions in the service manager.

QT (version 3 or higher)

http://www.trolltech.com/products/qt/

Necessary for the calibration service, the manual tracker, DIVE and the 3D viewer.

The Graphviz package (v1.8.10 or higher)

http://www.research.att.com/sw/tools/graphviz/download.html

Necessary for graph layout within DIVE.

Coin (v2.0.0 or higher) and SoQT (v1.0.2 or higher) or (preferred) SoXt (v 1.2 or higher)

http://www.coin3d.org/

Necessary for the 3D viewer.
The current version in the Lab is Coin 2.3.0, SoQt 1.0.2 and SoXt 1.2.2

If you can, please use SoXt instead of SoQt. It is much more stable, with SoQt spurious Viewer crashes occur.

JFern (v3.0.0 or higher)

http://sourceforge.net/projects/jfern

Necessary for the user interface controller. Note that you need Java v1.4 or higher for JFern to work correctly.

JRio (v0.2.0 or higher)

http://sourceforge.net/projects/cirrus

Needed by JFern.

TNT (v1.2.0 or higher) and JAMA-C++ (v1.2.1 or higher)

http://math.nist.gov/tnt/download.html

An efficient matrix library used by the experimental DWARF Ubitrack subsystem. Installation is extremely simple, as both TNT and JAMA-C++ consist just of several header files. The rpm's provided below are for SuSE 9.0, but should be ok for all Linux systems adhering to the FHS.



I Attachment sort Action Size Date Who Comment
Coin-2.0.0-3.i386.rpm manage 10732.3 K 14 Aug 2003 - 15:22 OtmarHilliges Coin for SuSE 8.x & XFree4.3
SoQt-1.0.2-1.i386.rpm manage 1615.0 K 14 Aug 2003 - 15:23 OtmarHilliges SoQt Window binding for SuSE 8.x
simage-1.2.2-1.i386.rpm manage 81.5 K 14 Aug 2003 - 15:18 OtmarHilliges simage for SuSE 8.x
omniORB-4.0.2-1.i386.rpm manage 31635.9 K 14 Aug 2003 - 15:20 OtmarHilliges omniORB 4.0.2 for SuSE 8.x
omniORBpy-2.2-1.i386.rpm manage 668.7 K 14 Aug 2003 - 15:20 OtmarHilliges omniPython for SuSE 8.x
OpenORB-1.3.0-1.i386.rpm manage 5128.2 K 14 Aug 2003 - 15:28 OtmarHilliges OpenORB (for Java) SuSE Linux
jakarta-log4j-1.2.8-1.i386.rpm manage 2162.7 K 14 Aug 2003 - 15:30 OtmarHilliges Logging framework for Java SuSE Linux
openslp-1.0.10-1.i386.rpm manage 370.1 K 14 Aug 2003 - 15:32 OtmarHilliges openSLP SuSE 8.x
xercesc-2.1.0-2.i386.rpm manage 4991.9 K 14 Aug 2003 - 15:33 OtmarHilliges xerces XML Parser SuSE 8.x
SoQt-1.0.2-1.src.rpm manage 633.5 K 29 Aug 2003 - 11:38 Main.hilliges SoQt Source RPM
SoQtDRI-1.0.2-3.i586.rpm manage 744.9 K 09 Jan 2004 - 14:16 Main.hilliges SoQt 1.0.2 for SuSE 9.0 linked w DRI
simage-1.6.0-1.src.rpm manage 589.2 K 26 Jan 2004 - 15:13 Main.hilliges simage 1.6.0 Source RPM
simage-1.6.0-1.i586.rpm manage 78.3 K 26 Jan 2004 - 15:14 Main.hilliges simage 1.6.0 compiled for SuSE9.0
JFern-3.0.0alpha-2.i586.rpm manage 691.2 K 14 Feb 2004 - 14:24 Main.hilliges JFern-3.0.0 for SuSE9.0
JRio-0.2.0-1.i586.rpm manage 476.3 K 14 Feb 2004 - 14:26 Main.hilliges Rio-0.2.0 for SuSE9.0
JFern-3.0.0alpha-2.src.rpm manage 785.6 K 14 Feb 2004 - 14:36 Main.hilliges JFern-3.0.0 source rpm
JRio-0.2.0-1.src.rpm manage 579.4 K 14 Feb 2004 - 14:39 Main.hilliges JRio-0.2.0 source rpm
TNT-1.2.0-1.i586.rpm manage 61.3 K 09 Jun 2004 - 11:48 Main.wagnerm TNT 1.2.0 RPM
JAMA-C-1.2.1-1.i586.rpm manage 48.3 K 09 Jun 2004 - 11:49 Main.wagnerm JAMA 1.2.1 RPM
Coin-2.3.0-1.i586.rpm manage 11000.6 K 24 Nov 2004 - 12:07 Main.wagnerm Coin 2.3.0
SoXt-1.2.2-2.i586.rpm manage 904.4 K 24 Nov 2004 - 12:31 Main.wagnerm SoXt 1.2.2 for Coin 2.3.0
openslp-1.2.0-2.i586.rpm manage 396.7 K 27 Nov 2004 - 14:45 Main.wagnerm openslp for SuSE 9.0
openslp-1.2.0-2.src.rpm manage 544.8 K 27 Nov 2004 - 14:46 Main.wagnerm src rpm for openslp 1.2.0

Edit | Attach | Refresh | Diffs | More | Revision r1.30 - 23 Mar 2005 - 11:59 - NikolasDoerfler

Lehrstuhl für Computer Aided Medical Procedures & Augmented Reality    rss.gif